天天看點

poj 2240 Arbitrage(Floyd)--Java

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26393 Accepted: 11121

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
      

Sample Output

Case 1: Yes
Case 2: No
      

Source

Ulm Local 1996

import java.util.*;
public class Main {

    static double map[][];
    static String name[];
    static int n,m;
    public static void floyd()
    {
        int i,j,k;
        for(k=1;k<=n;k++)
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                {
                    if(map[i][j]<map[i][k]*map[k][j])
                    {
                        map[i][j]=map[i][k]*map[k][j];
                    }
                }
    }
    public static void main(String[] args) {
        // write your code here
        Scanner in=new Scanner(System.in);
        int count=0;
        while(in.hasNext()) {
            count++;
            n = in.nextInt();
            if(n==0) return;

            map = new double[n + 1][n + 1];
            name = new String[n + 1];

            for (int i = 1; i <= n; i++) {
                map[i][i] = 1;
            }

            for (int i = 1; i <= n; i++) {
                name[i] = in.next();
            }

            m = in.nextInt();

            for (int i = 0; i < m; i++) {
                String str1 = in.next();
                String x = in.next();
                String str2 = in.next();
                int a = 0, b = 0;
                for (int j = 1; j <= n; j++) {
                    if (name[j].equals(str1)) {
                        a = j;

                    }
                    if (name[j].equals(str2)) {
                        b = j;
                    }
                }
                map[a][b] = Double.parseDouble(x);
            }

            floyd();

            boolean flag=false;

            for(int i=1;i<=n;i++)
            {
                if(map[i][i]>1)
                {
                    flag=true;
                    break;
                }
            }

            if(flag){
                System.out.println("Case "+count+": Yes");
            }
            else{
                System.out.println("Case "+count+": No");
            }


        }
    }

}