天天看點

【基礎dp】Max Sum Plus Plus Max Sum Plus Plus

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20745    Accepted Submission(s): 6900

Problem Description Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.

Process to the end of file.

Output Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3
        

Sample Output

6
8


   
    
     Hint
    
Huge input, scanf and dynamic programming is recommended.

   
    
        

Author JGShining(極光炫影)  

用正常的方法寫會超記憶體逾時間,是以此處用滾動數組;

進行m次操作,是以最外層循環為m次;

dp[i][j]表示處理到第i點,分成cnt組的總和,j表示滾動數組中的哪一個。

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;



int n,m;
int a[1000007];
int dp[1000007][2];

int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);

        int t1=0,t2=1;
        memset(dp,0,sizeof dp);

        for(int i=1;i<=m;i++)
        {
            dp[i][t2]=(dp[i-1][t1])+a[i];

            int ma=dp[i-1][t1];

            for(int j=i+1;j<=n;j++)
            {
                ma=max(ma,dp[j-1][t1]);
                dp[j][t2]=max(dp[j-1][t2],ma)+a[j];

            }
            swap(t1,t2);

        }

        int ans=-99999999;
        for(int i=m;i<=n;i++)
        {
            ans=max(ans,dp[i][t1]);
        }
        printf("%d\n",ans);

    }

    return 0;
}