天天看點

PAT (Advanced Level) 1038. Recover the Smallest Number (30) 串聯最小字元串,排序

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87
      

Sample Output:

22932132143287      
字元串排序。将這些整數看成字元串,要把這些字元串串聯起來得到最小的字元串。      
由于高位權重較大,故字首越小的字元串越應該放前面。      
所有字元串串聯起來後,在整串中,對于任意兩個字元串s1和s2,有兩種情況:***s1%%%s2###或***s2%%%s1###。      
我們可以直接比較s1+s2和s2+s1。若s1+s2<s2+s1,即兩個字元串串聯時,s1放前面得到的字元串較小,說明他們放到整串中時,s1也應該放s2前面,即***s1%%%s2###小于***s2%%%s1###。      
故我們可以直接對所有字元串從小到大排序。      
輸出時注意去掉第一個非全0字元串前面的0,若全為全0字元串則輸出0。      
/*2015.7.24cyq*/
#include <iostream>
#include <vector>
#include <string>
#include <sstream>
#include <algorithm>
using namespace std;

int str2int(const string s1){
	stringstream ss;
	ss<<s1;
	int k;
	ss>>k;
	return k;
}

bool cmp(const string s1,const string s2){
	return s1+s2<s2+s1;
}

int main(){
	int N;
	cin>>N;
	vector<string> a;
	string s;
	for(int i=0;i<N;i++){
		cin>>s;
		a.push_back(s);
	}
	sort(a.begin(),a.end(),cmp);
	int k=0;
	while(k<N&&(str2int(a[k])==0))//去掉所有全0的片段
		 k++;
	if(k==N){
		cout<<0;
		return 0;
	}
	if(k<N){//第一個不是全0的片段,若前面有0需去掉
		int len=a[k].size();
		int i=0;
		while(a[k][i]=='0')
			i++;
		while(i<len){
			cout<<a[k][i];
			i++;
		}
		k++;
	}
	while(k<N){
		cout<<a[k];
		k++;
	}
	return 0;
}