天天看點

POJ 2236 - Wireless Network (并查集)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

1. "O p" (1 <= p <= N), which means repairing computer p.

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
      

Sample Output

FAIL
SUCCESS
      

題意:

      電腦被全部損壞,給出各個電腦的坐标,修好的電腦之間距離不超過d可以聯系,也可以通過其他修好的電腦間接相連。‘O’表示要維修的電腦,‘S’後有兩個詢問的電腦x , y,詢問他們是否能夠聯系。

思路:

     判斷兩台修好的電腦距離與d之間的關系,如果小于等于d就合并,最後判斷詢問的x,y是否是同一個祖先。

    讀入字元的的時候要小心,一開始忘記了!=EOF結果時間超限好幾次。

代碼:

#include<stdio.h>
#include<string.h>
int f[1010],n,d,book[1010];
int x[1010],y[1010];
void init()
{
	int i;
	for(i=1;i<=n;i++)	
		f[i]=i;
	return;
}
int dis(int i,int j)
{
	if((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])<=d*d)
		return 1;
	return 0;
}
int getf(int v)
{
	if(f[v]==v)
		return v;
	else
		f[v]=getf(f[v]);
	return f[v];
}
void merge(int x,int y)
{
	int t1,t2;
	t1=getf(x);
	t2=getf(y);
	if(t1!=t2)
	{
		f[t2]=t1;
	}
	return;
}
int main()
{
	int i,j,k,a,b;
	char ch;
	while(scanf("%d%d",&n,&d)!=EOF)
	{
		init();
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		while(scanf("%c",&ch)!=EOF)
		{
			if(ch=='O')
			{
				scanf("%d",&a);
				book[a]=1;
				for(i=1;i<=n;i++)
				{
					if(i!=a&&book[i]==1&&dis(i,a))
					{
						merge(i,a);
					}
				}
			}
			if(ch=='S')
			{
				scanf("%d%d",&a,&b);
				if(getf(a)==getf(b))
					printf("SUCCESS\n");
				else
					printf("FAIL\n");
			}
		}
	}
	return 0;
}
           

繼續閱讀