Kindergarten
Time Limit: 2000MS | Memory Limit: 65536K |
Total Submissions: 5317 | Accepted: 2589 |
Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
Case 1: 3
Case 2: 4
Source
2008 Asia Hefei Regional Contest Online by USTC
題意:在幼稚園中。全部男孩間都互相認識,女孩彼此也都認識。有一些男孩跟一些女孩認識,如今給定這些認識關系,標明一個最大的點集使得裡面每一個人都互相認識。
題解:二分圖的獨立集僅僅從二分圖G = (X,Y;E)選取一些點v屬于{X, Y}。使得點集v中随意兩點間沒有通過邊連結。而二分圖的最大獨立集模型就是求取max|v|。
有例如以下公式:
最大獨立集頂點個數 = 節點數(|X|+|Y|)- 最大比對數。
#include <stdio.h>
#include <string.h>
#define maxn 205
bool G[maxn][maxn], visy[maxn];
int girl[maxn], boy[maxn];
int g, b, m, cas = 1;
void getMap() {
int u, v;
memset(G, 0, sizeof(G));
while(m--) {
scanf("%d%d", &u, &v);
G[u][v] = true;
}
}
int findPath(int x) {
int i;
for(i = 1; i <= b; ++i) {
if(!G[x][i] && !visy[i]) {
visy[i] = 1;
if(boy[i] == -1 || findPath(boy[i])) {
boy[i] = x; return 1;
}
}
}
return 0;
}
int MaxMatch() {
int i, ans = 0;
memset(girl, -1, sizeof(girl));
memset(boy, -1, sizeof(boy));
for(i = 1; i <= g; ++i) {
memset(visy, 0, sizeof(visy));
ans += findPath(i);
}
return ans;
}
void solve() {
printf("Case %d: %d\n", cas++, g + b - MaxMatch());
}
int main() {
while(scanf("%d%d%d", &g, &b, &m), g | b | m) {
getMap();
solve();
}
return 0;
}
轉載于:https://www.cnblogs.com/lcchuguo/p/5267101.html