天天看點

pat 甲級 1003 Emergency 1003. Emergency (25)

1003. Emergency (25)

時間限制 400 ms

記憶體限制 65536 kB

代碼長度限制 16000 B

判題程式 Standard 作者 CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
      

Sample Output

2 4      

題意:

求單源點對最短路徑數和最大的點權重之和。

思路:

floyd是辦不到的,隻能在dijstra算法上加計數dp類型的優化,統計從起點到目前節點的最短路徑的條數和到該點為止

所能找到的最多的急救隊的數。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 550;
const int INF = 0x3f3f3f3f;
int m,n,st,ed;
int have[maxn];
int vis [maxn];
int e[maxn][maxn];
int dist[maxn];
int lead[maxn];
int diff[maxn];
int main()
{
    memset(vis,0,sizeof(vis));
    scanf("%d%d%d%d",&n,&m,&st,&ed);
    for(int i = 0;i < n;i++)
        scanf("%d",&have[i]);
    for(int i= 0;i < maxn;i++)
        for(int j = 0;j < maxn;j++)
            if(i != j)
                e[i][j] = INF;
            else
                e[i][j] = 0;
    for(int i =0;i < m;i++)
    {
        int a,b,l;
        scanf("%d%d%d",&a,&b,&l);
        e[a][b] = e[b][a] = l;
    }
    if(st == ed)//沒有這個第二組樣例是過不了的,卡了很久
    {
        printf("%d %d\n",1,have[st]);
        return 0;
    }
    for(int i = 0;i < n;i++)
    {
        diff[i] = 1;
        dist[i] = e[st][i];
        if(dist[i] != INF)
            lead[i] = have[st]+have[i];
    }
    dist[st] = 0;
    vis[st] = 1;
    for(int i = 1;i < n;i++)
    {
        int minn = INF;
        int v = 0;
        for(int j = 0;j < n;j++)
        {
            if(vis[j])continue;
            if(minn > dist[j])
            {
                minn = dist[j];
                v = j;
            }
        }
        if(v == ed)
        {
            printf("%d %d\n",diff[v],lead[v]);
            break;
        }
        vis[v] = 1;
        for(int j = 0;j < n;j++)
        {
            if(!vis[j]&&e[v][j]!=INF)
            {
                if(dist[j] > dist[v] + e[v][j])
                {
                    dist[j] = dist[v] + e[v][j];
                    lead[j] = lead[v] + have[j];
                    diff[j] = diff[v];
                }
                else if(dist[j] == dist[v]+e[v][j])
                {
                    diff[j]+= diff[v];
                    if(lead[v]+have[j]>lead[j])
                        lead[j] = lead[v] + have[j];
                }
            }
        }
    }
    return 0;
}