天天看點

POJ-2406 Bellman解決無向圖+負權邊/SPFA

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: N, M, and W 

Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 

Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8      

Sample Output

NO
YES      

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

題目大意:有F個牧場,每個牧場有N個區域,看成頂點也可以,這些區域又有M條路(無向的),這些路徑都有一定的花費時間,有W個蟲洞(單向邊),這些蟲洞可以穿梭傳回t秒前,就問有沒有存在一條路徑使其能夠回到提前起點(舉個栗子比如2--->3--->4花費的時間為30s,4--->2之間有一個蟲洞能夠回溯的時間為31s,那就滿足題意了,如果回溯時間是30s或者小于30s,那就說明這條路不滿足題意)

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include<cmath>
using namespace std;
#define rep(i,a,b) for(int i=a;i<=b;i++)
const int INF=0x3f3f3f3f;
struct node
{
    int u,v,w;
}num[2550];
int dis[600];
int n;
int e[600][600];
int main()
{
    int F;
    scanf("%d",&F);
    while(F--)
    {
        memset(num,0,sizeof num);
        //memset(e,INF,sizeof e);
        memset(dis,0,sizeof dis);
        int m,t;
        scanf("%d%d%d",&n,&m,&t);
        rep(i,1,m)
        {
            int x,y;
            scanf("%d%d%d",&num[i].u,&num[i].v,&num[i].w);
        }
        rep(i,m+1,m+t)
        {
            int x,y,z;
            scanf("%d%d%d",&num[i].u,&num[i].v,&num[i].w);
            num[i].w=-num[i].w;//将蟲洞看成負邊權
        }
        rep(i,1,n)
        dis[i]=INF;dis[1]=0;
        rep(k,1,n-1)
        {
            bool flag=0;
                rep(i,1,m)
                {
                    if(dis[num[i].u]>dis[num[i].v]+num[i].w)//因為不确定這個無向邊到底是
//從哪個點到哪個點,是以就要将兩個方向都看一下
                    dis[num[i].u]=dis[num[i].v]+num[i].w,flag=true;
                    if(dis[num[i].v]>dis[num[i].u]+num[i].w)
                    dis[num[i].v]=dis[num[i].u]+num[i].w,flag=true;
                }
                rep(j,m+1,m+t)
                if(dis[num[j].v]>dis[num[j].u]+num[j].w)
                    dis[num[j].v]=dis[num[j].u]+num[j].w,flag=1;
                if(!flag) break;
        }
        bool fl=0;
        rep(i,1,m+t)
        if(dis[num[i].v]>dis[num[i].u]+num[i].w) fl=1;
        if(fl)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
           

SPFA

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#define _clr(x,a) memset(x,a,sizeof(x));
using namespace std;
const int N=600;
const int INF=0x3f3f3f3f;
int t;
int n,m,w;
int u,v,wi;
int g[N][N];
int dis[N];
bool vis[N];
int cnt[N];
void spfa(){
    memset(vis,0,sizeof vis);
    memset(dis,INF,sizeof dis);
    memset(cnt,0,sizeof cnt);
    vis[1]=true;
    dis[1]=0;
    cnt[1]=1;
    queue<int> q;
    q.push(1);
    while(!q.empty()){
        int cur=q.front();
        q.pop();
        for(int i=1;i<=n;i++){

            if(dis[i]>dis[cur]+g[cur][i]){
                dis[i]=dis[cur]+g[cur][i];
                if(!vis[i]){
                    cnt[i]++;
                    //判斷負環 第n+1次加入隊列
                    if(cnt[i]>n){
                            printf("YES\n");
                        return ;
                    }
                    q.push(i);
                    vis[i]=true;
                }
            }
        }
        vis[cur]=false;
    }
    printf("NO\n");
}
int main(void){
    //freopen("data.txt","r",stdin);
    scanf("%d",&t);
    while(t--){
        _clr(g,INF);
        scanf("%d%d%d",&n,&m,&w);
        while(m--){
            scanf("%d%d%d",&u,&v,&wi);
            if(wi<g[u][v]){//這裡一定要有判斷
                g[u][v]=g[v][u]=wi;
            }
            g[u][u]=g[v][v]=0;
        }
        while(w--){
            scanf("%d%d%d",&u,&v,&wi);
            if(-wi<g[u][v]){//這裡一定要有判斷
                g[u][v]=-wi;
            }
        }
       spfa();
    }
    return 0;
}