天天看點

【HDU 6047】Maximum Sequence(DP) Maximum Sequence

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 400    Accepted Submission(s): 215

Problem Description Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1…a2n . Just like always, there are some restrictions on  an+1…a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ ∑2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.

Input The input contains no more than 20 test cases.

For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.

1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output For each test case, print the answer on one line: max{ ∑2nn+1ai } modulo  109 +7。  

Sample Input

4
8 11 8 5
3 1 4 2
        

Sample Output

27

   
    
     Hint
    
For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

   
    
        

Source 2017 Multi-University Training Contest - Team 2  

比賽的時候剛吃完漢堡,看公式都想了半天,學長說用priority_queue,按着自己思路敲了一遍,學長前腳交了一發A,我跟着交也A了,就是時間多了幾百MS...晚上看題解才覺得大神真的厲害,做這種比賽簡直心态炸裂,唉。

關鍵是預處理一遍最大值。

#include <iostream>
#include <cstdio>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<queue>
using namespace std;
int a[250010<<1],b[250010],Max[250010];
const int mod = 1e9+7;
int main(void)
{
    int n,temp;
    while(~scanf("%d",&n))
    {
        memset(Max,0,sizeof(Max));
        for(int i = 1; i <= n; ++i)
        {
            scanf("%d",&temp);
            a[i] = temp-i;
        }
        for(int i = n; i > 0; --i)
            Max[i] = max(Max[i+1],a[i]);
        for(int i = 1; i <= n; ++i)
            scanf("%d",&b[i]);
        priority_queue<int> que;
        for(int i = 1; i <= n; ++i)
            que.push(Max[b[i]]);
        int ans=0,tmp=0;
        for(int i = n+1; i <= n<<1; ++i)
        {
            if(tmp>que.top())
                a[i] = tmp-i;
            else
                a[i] = que.top()-i, que.pop();
            ans = (ans+a[i]+i)%mod;
            tmp = max(tmp,a[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}