天天看點

USACO Section 1.2.5 Palindromic Squares

題目

Palindromic Squares

Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10
      

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696
      

思路

其實這個題目很簡單,可是為毛我做了好久呢?其實,主要是我一貫試用cpp的string,這會想練練純c,突然發現這玩意好繁瑣。。又加上邊聊邊寫,于是乎一道水題搞了一個多小時。

學習: malloc(sizeof(char)*100); // 不清零 calloc(100,sizeof(char)); // 清零 然後,沒了。

代碼

#include <cstdio>
#include <cstring>
#include <cstdlib>
const int dr[22]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I','J','K'};
const int N=300;
int n;
char * mir(char *a){
	int l=strlen(a);
	char *b=(char*)calloc(22,sizeof(char));
	for (int i(0);i<l;i++) b[i]=a[l-i-1];
	b[l]='\0';
	return b;
}
char * base(int k,int n){
	char *s=(char*)calloc(22,sizeof(char));
	while (k){
		int l=strlen(s);
		s[l]=dr[k%n];
		s[l+1]='\0';
		k/=n;
	}
	return mir(s);
}
int main(){
	freopen("palsquare.in","r",stdin);
	freopen("palsquare.out","w",stdout);
	scanf("%d",&n);
	for (int i(1);i<=N;i++){
		char *b1=base(i,n);
		char *b2=base(i*i,n);
		if (!strcmp(b2,mir(b2))){
		   printf("%s %s\n",b1,b2);
		}
	}
	return 0;
}