天天看點

Spinning Wheels(暴力)

Spinning Wheels

1998 ACM NE Regionals

Each of five opaque spinning wheels has one or more wedges cut out of its edges. These wedges must be aligned quickly and correctly. Each wheel also has an alignment mark (at 0 degrees) so that the wheels can all be started in a known position. Wheels rotate in the `plus degrees' direction, so that shortly after they start, they pass through 1 degree, 2 degrees, etc. (though probably not at the same time).

This is an integer problem. Wheels are never actually at 1.5 degrees or 23.51234123 degrees. For example, the wheels are considered to move instantaneously from 20 to 25 degrees during a single second or even from 30 to 40 degrees if the wheel is spinning quickly.

All angles in this problem are presumed to be integers in the range 0 <= angle <= 359. The angle of 0 degrees follows the angle of 359 degrees. Each wheel rotates at a certain integer number of degrees per second, 1 <= speed <= 180.

Wedges for each wheel are specified by an integer start angle and integer angle size (or `extent'), both specified in degrees. Wedges in the test data will be separated by at least one degree. The 'extent' also includes the original "degree" of the wedge, so '0 180' means degrees 0..180 inclusive -- one more than most would imagine.

At the start, which is time 0, all the wheels' alignment marks line up. Your program must determine the earliest time (integer seconds) at or after the start that some wedge on each wheel will align with the wedges on the other wheel so that a light beam can pass through openings on all five wedges. The wedges can align at any part of the rotation.

PROGRAM NAME: spin

INPUT FORMAT

Each of five input lines describes a wheel.

The first integer on an input line is the wheel's rotation speed. The next integer is the number of wedges, 1 <= W <= 5. The next W pairs of integers tell each wedge's start angle and extent.

SAMPLE INPUT (file spin.in)

30 1 0 120
50 1 150 90
60 1 60 90
70 1 180 180
90 1 180 60
      

OUTPUT FORMAT

A single line with a single integer that is the first time the wedges align so a light beam can pass through them. Print `none' (lower case, no quotes) if the wedges will never align properly.

SAMPLE OUTPUT (file spin.out)

9      

      題意:

      給出 5 個輪子的角速度 v,還有缺口個數 N 。後隔出個 N 對缺口的起始位置和長度。同一時間向前滾動,問哪一秒鐘能同時穿過所有的輪子。

      思路:

      暴力。直接搜尋 0 ~ 359 秒内的轉動情況,同時标記好每一度數有幾個輪子能被穿過,如果存在某一度數的輪子數為 5 ,說明這一秒中能被穿過,輸出這個時間即可。如果 360 内都不能達到,則說明是 none。原以為會有公式,但是資料隻有 5 個輪子,且缺口數最多也隻有 5 ,是以直接暴力即可。

      AC:

/*
ID:sum-g1
LANG:C++
PROG:spin
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>

using namespace std;

typedef struct {
    int speed, num;
    int angle[10], len[10];
} node;

node no[10];
int ans[365];

bool check() {
    for (int i = 0; i < 360; ++i)
        if (ans[i] == 5) return true;
    return false;
}

void solve () {

    for (int t = 0; t <= 359; ++t) {
        memset(ans, 0, sizeof(ans));

        for (int i = 1; i <= 5; ++i) {
            for (int j = 1; j <= no[i].num; ++j) {
                int from = no[i].angle[j] + t * no[i].speed;
                for (int tt = from; tt <= from + no[i].len[j]; ++tt)
                    ++ans[tt % 360];
            }
        }

        if(check()) {
            printf("%d\n", t);
            return;
        }
    }

    printf("none\n");
}

int main() {

    freopen("spin.in","r",stdin);
    freopen("spin.out","w",stdout);

    for (int i = 1; i <= 5; ++i) {
        scanf("%d%d", &no[i].speed, &no[i].num);
        for (int j = 1; j <= no[i].num; ++j) {
            scanf("%d%d", &no[i].angle[j], &no[i].len[j]);
        }
    }

    solve();

    return 0;
}