天天看點

USACO1.2.4 Palindromic Squares(回文平方數)

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10
      

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1  1
2  4
3  9
11  121
22  484
26  676
101  10201
111  12321
121  14641
202  40804
212  44944
264  69696
      

題目大意:給定一個進制B(2<=B<=20 十進制),輸出所有的大于等于1小于等于300且它的平方用B進制表示時是回文數的數,用’A’,’B’……表示10,11 等等。

輸出格式:每行兩個數,第二個數是第一個數的平方,且第二個數是回文數.(注意:這兩個數都應該在B那個進制下)

解題思路:好像沒什麼難的,主要就是考進制轉換,以及回文數的判斷。模拟進制轉換過程即可,窮舉1到300的所有平方數,轉進制,比較,就OK了,除非你不會怎麼轉進制。

/*
USER:xingwen wang
TASK:palsquare
LANG:C
*/
#include<stdio.h>
#include<string.h>
#define MAXN 300
int Transform(int num);/*進制轉換*/ 
char b[30],a[25]={"0123456789ABCDEFGHIJ"};
int n;
int main()
{
    freopen("palsquare.in","r",stdin);
    freopen("palsquare.out","w",stdout);
    int i,j,L,r;
    char p[35];
    scanf("%d",&n);
    for(i=1;i<=MAXN;i++)
    {
         r=Transform(i*i);
         L=0; 
         while(L<=r&&b[L]==b[r])
         {
               L++;r--;
         }  
         if(L>r)
         {
              strcpy(p,b);
              r=Transform(i);
              for(j=r;j>=0;j--)
              printf("%c",b[j]);
              printf(" %s\n",p);/*它是回文數,是以不需要逆序輸出*/ 
         }
    }
    return 0;
}
int Transform(int num)
{
     int i=-1;
     while(num>0)
     {
         b[++i]=a[num%n];
         num/=n;
     }
     return i;
}