天天看點

HDU-5879 Cure(精度)(極限)Cure

Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7400    Accepted Submission(s): 1099

Problem Description Given an integer   n , we only want to know the sum of   1/k2  where   k  from   1  to   n .  

Input There are multiple cases.

For each test case, there is a single line, containing a single positive integer   n .  

The input file is at most 1M.

Output The required sum, rounded to the fifth digits after the decimal point.  

Sample Input

1
2
4
8
15
        

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044
        

首先要知道∑1/(i*i)有極限,是以計算到一定數值以後結果會不再變化(小數點後後5位),然後找到邊界1e6。

注意1M的輸入。and atoi()

//下面盜用隊友代碼

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
char str[10000005];
int main()
{
    while(~scanf("%s",str))
    {
        int len = strlen(str);
        double tosum = 0;
        if(len <= 6)
        {
            if(len < 6 || str[0] == '1')
            {
                int n = atoi(str);
                for(int i = 1;i <= n;i++)
                {
                    double tmp = i;
                    tosum += 1/(tmp*tmp);
                }
                printf("%.5f\n",tosum);
            }
            else
                printf("1.64493\n");
         }
         else if(len > 6)
                printf("1.64493\n");
    }
    return 0;
}