天天看點

省賽熱身賽8-A - Ace of Aces*

A - Ace of Aces

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit Status

Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998
      

Sample Output

2
Nobody
998
      

【分析】找出現次數最多的數字,如果次數最多的兩個或多個出現次數相同,輸出Nobody,否則輸出數字。

#include<bits/stdc++.h>
using namespace std;
int a[1005];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		int p=q=0;
		while(n--)
		{
			scanf("%d",&b);
			a[b]++;
			if(a[b]>=p)
			{
				q=p;
				p=a[b];
				c=b;
			}
		}
		if(q==p)cout<<"Nobody\n";
		else cout<<c<<endl;
	}
	return 0;
}