天天看點

UVa 1225 - Digit Counting(模拟)

1225 - Digit Counting

Time limit: 3.000 seconds

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequenceof consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number oftimes each digit (0 to 9) appears in the sequence.

For example, with N = 13, the sequence is:12345678910111213In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and eachdigit from 4 to 9 appears once.

After playing for a while, Trung gets bored again. He now wants towrite a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of datasets which is a positive integer and is not bigger than 20. The following lines describe the data sets.For each test case, there is one single line containing the number N.

Output

For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.

Sample Input

2

3

13

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

思路:

  1. 難點在于有多位數字的時候轉換為字元串輸出
#include<iostream>
#include<cstring>
using namespace std;

int main()
{
    int a[15];        //%10得到的數為0~9,是以數組長度10即可,大一點沒關系
    int t,n;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            int x=i;
            while(x)
            {
                int num=x%10;
                a[num]++;        //打表,隻要出現與下标相同的數字,就+1
                x/=10;        
            }
        }
        for(int i=0;i<10;i++)    
        {
            if(i)cout<<" ";        //記住該方法!!!
            cout<<a[i];
        }
        cout<<endl;
    }
    return 0;
}

           

繼續閱讀