天天看點

省賽熱身賽8-G - Lunch Time(字元串處理&&模拟)

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Submit Status

Description

The 999th Zhejiang Provincial Collegiate Programming Contest will be held in Marjar University. The canteen of Marjar University is making preparations for this grand competition. The canteen provides a lunch set of three types: appetizer, main course and dessert. Each type has several dishes with different prices for choosing.

Edward is the headmaster of Marjar University. One day, to inspect the quality of dishes, he go to the canteen and decides to choose a median set for his lunch. That means he must choose one dish from each of appetizers, main courses and desserts. Each chosen dish should at the median price among all dishes of the same type.

For example, if there are five dessert dishes selling at the price of 2, 3, 5, 10, 30, Edward should choose the dish with price 5 as his dessert since its price is located at the median place of the dessert type. If the number of dishes of a type is even, Edward will choose the dish which is more expensive among the two medians.

You are given the list of all dishes, please write a program to help Edward decide which dishes he should choose.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains three integers S, M and D (1 <= S, M, D <= 100), which means that there are S dishes of appetizer, M dishes of main course and D dishes of dessert.

Then followed by three parts. The first part contains S lines, the second and the last part contains M and D lines respectively. In each line of the three parts, there is a string and an integer indicating the name and the price of a dish. The name of dishes will only consist of non-whitespace characters with no more than 50 characters. The price of dishes are non-negative integers less than or equal to 1000. All dish names will be distinct.

Output

For each test case, output the total price of the median set, together with the names of appetizer, main course and dessert, separated by a single space.

Sample Input

2
1 3 2
Fresh_Cucumber 4
Chow_Mein 5
Rice_Served_with_Duck_Leg 12
Fried_Vermicelli 7
Steamed_Dumpling 3
Steamed_Stuffed_Bun 4
2 3 1
Stir-fried_Loofah_with_Dried_Bamboo_Shoot 33
West_Lake_Water_Shield_Soup 36
DongPo's_Braised_Pork 54
West_Lake_Fish_in_Vinegar 48
Longjing_Shrimp 188
DongPo's_Crisp 18
      

Sample Output

15 Fresh_Cucumber Fried_Vermicelli Steamed_Stuffed_Bun
108 West_Lake_Water_Shield_Soup DongPo's_Braised_Pork DongPo's_Crisp
      

【分析】題意:給你3中食物的數量,每種食物買一樣,按價格升序買中間的那個,如果是偶數,買中間的兩個中價格高的那個。輸出總價格和買的食物的名稱;

用結構體存儲名稱和價格,一部分一部分的排序,然後标記、輸出。代碼有點長、麻煩

#include<bits/stdc++.h>
using namespace std;
struct cook{
	string name;
	int price;
}c[305];
string aa,bb,cc;
bool cmp(cook x,cook y)
{
	return x.price<y.price;
}
int main()
{
    int t,s,m,d;
    scanf("%d",&t);
    while(t--)
    {
    	aa="";bb="";cc="";
    	int ans=0;
    	scanf("%d%d%d",&s,&m,&d);
    	for(int i=0;i<s+m+d;i++)
    	{
    		cin>>c[i].name;
		scanf("%d",&c[i].price);
	}//
    	sort(c,c+s,cmp);
    	if(s%2==0)
    	{
    		if(c[s/2].price>c[s/2-1].price)
    		{
    			ans+=c[s/2].price;
    			aa=c[s/2].name;
			}
			else {
				ans+=c[s/2-1].price;
    			aa=c[s/2-1].name;
			}
		}
		else{
		    ans+=c[s/2].price;
    		    aa=c[s/2].name;//cout<<ans<<endl;cout<<"ok\n";
		}
		sort(c+s,c+s+m,cmp);
		if(m%2==0)
    	        {
    		    if(c[s+m/2].price>c[s+m/2-1].price)
    		    {
    			ans+=c[s+m/2].price;
    			bb=c[s+m/2].name;
			}
			else {
				ans+=c[s+m/2-1].price;
    			bb=c[s+m/2-1].name;
			}
		    }
		    else{
		//	cout<<"s+m/2="<<s+m/2<<endl;
			ans+=c[s+m/2].price;
    		    bb=c[s+m/2].name;
		}
		sort(c+s+m,c+s+m+d,cmp);
		if(d%2==0)
    	        {
    		    if(c[s+m+d/2].price>c[s+m+d/2-1].price)
    		    {
    			ans+=c[s+m+d/2].price;
    			cc=c[s+m+d/2].name;
		    }
		    else {
			ans+=c[s+m+d/2-1].price;
    			cc=c[s+m+d/2-1].name;
		    }
		}
		else{
		    ans+=c[s+m+d/2].price;
    		    cc=c[s+m+d/2].name;
		}
		cout<<ans<<" "<<aa<<" "<<bb<<" "<<cc<<endl;
	}
    return 0;
}