天天看點

LightOJ - 1058 Parallelogram Counting (數學幾何&技巧)給n個點求組成平行四邊形個數

LightOJ - 1058 Parallelogram Counting
Time Limit: 2000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

Submit Status

Description

There are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as{A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.

Input

Input starts with an integer T (≤ 15), denoting the number of test cases.

The first line of each test case contains an integer n (1 ≤ n ≤ 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.

Output

For each case, print the case number and the number of parallelograms that can be formed.

Sample Input

2

6

0 0

2 0

4 0

1 1

3 1

5 1

7

-2 -1

8 9

5 7

1 1

4 8

2 0

9 8

Sample Output

Case 1: 5

Case 2: 6

//題意:輸入一個n,再輸入n個點的坐标。

給你n個點的坐标讓你求出這n個點可以組成幾個平行四邊形。

//思路:

因為平行四邊形的兩條對角線的交點是唯一的,是以先求出這n個點所能組成的所有線段的中點(n*(n-1)/2個中點),對其進行排序後,對這些中點進行計算,如果在一個中點處有num條線段相交,那麼在這個中點處可以組成num*(num-1)/2個平行四邊形。最所有中點模拟一遍對其求和即為所得。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
struct zz
{
	int x;
	int y;
}p[N],mid[N*N];
int cmp(zz a, zz b)
{
	if(a.x==b.x)
		return a.y<b.y;
	return a.x<b.x;
}
int main()
{
	int t,n,i,j,T=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&p[i].x,&p[i].y);
		//sort(p,p+n,cmp);
		int k=0;
		for(i=0;i<n-1;i++)
		{
			for(j=i+1;j<n;j++)
			{
				mid[k].x=p[j].x+p[i].x;
				mid[k++].y=p[j].y+p[i].y;
			}
		}
		sort(mid,mid+k,cmp);
//		for(i=0;i<k;i++)
//			printf("%d %d-----\n",mid[i].x,mid[i].y);
//		printf("\n");
		int num=1;
		int sum=0;
		for(i=0;i<k-1;i++)
		{
			if(mid[i].x==mid[i+1].x&&mid[i].y==mid[i+1].y)
				num++;
			else 
			{
				sum+=(num*(num-1)/2);
				num=1;
			}
		}
		printf("Case %d: %d\n",T++,sum);
	}
	return 0;
}