天天看點

POJ-1276 Cash Machine(經典多重背包)

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10      

Sample Output

735
630
0
0      

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

Southeastern Europe 2002

題意:多重背包,給你一些錢,每一種錢有nk張,要求要你找出不超過cash的最大錢數。

分析:F[i][j]表示前I個物品能不能填到j,然後每個物品枚舉一下取多少個,直接暴力DP肯定不可取,會T掉,這種模型有很多種優化方法。

方法1:《挑戰程式設計競賽》中給的方法,改變F[i][j]的含義,此時F[I][J]表示前i種物品得到j時最多能剩下幾個i,那麼就有

f[i][j] = d[i] (f[i-1][j] >= 0) or f[i][j-w[i]]-1,空間上第一維可以省略掉。

#include <queue>
#include <vector>
#include <cstdio>
#include <utility>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int cash,n,ans,w[1005],d[1005],f[100005];
int main()
{
	cin.sync_with_stdio(false);
	while(cin>>cash>>n)
	{
		memset(f,-1,sizeof(f));
		for(int i = 1;i <= n;i++) cin>>d[i]>>w[i];
		for(int i = 1;i <= n;i++)
		{
			f[0] = d[i];
			for(int j = 1;j <= cash;j++)
			{
				if(f[j] >= 0) f[j] = d[i];
				else 
				 if(j >= w[i]) f[j] = f[j-w[i]] - 1;
			}
		}
		ans = 0;
		for(int j = cash;j;j--)
		 if(f[j] >= 0) 
		 {
		 	ans = j;
		 	break;
		 }
		cout<<ans<<endl;
	}
}
           

方法2: 《背包九講》中提到的,多重背包二進制優化法。

每種物品有d[i]個,我們可以把其拆分成log(d[i])種物品(1,2,4,....2^k,d[i] - 2^(k+1)+1),然後做一次01背包。

#include <queue>  
#include <vector>  
#include <cstdio>  
#include <utility>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
using namespace std;  
int cash,n,ans,w[1005],d[1005];
bool f[100005];
int main()
{
	cin.sync_with_stdio(false);
	while(cin>>cash>>n)
	{
		memset(f,0,sizeof(f));
		f[0] = true;
		for(int i = 1;i <= n;i++) 
		{
			cin>>d[i]>>w[i];
			int k = 1;
			for(;d[i]-2*k+1 > 0;k*=2)
			 for(int j = cash;j >= k*w[i];j--) f[j] = f[j] || f[j-k*w[i]];
			k = d[i]-k+1;
			for(int j = cash;j >= k*w[i];j--)  f[j] = f[j] || f[j-k*w[i]];
		}
		int j = cash;
		for(;j;j--) if(f[j]) break;
		cout<<j<<endl;
	}		
}