天天看點

PAT (Advanced Level) Practice — 1088 Rational Arithmetic (20 分)

題目連結:https://pintia.cn/problem-sets/994805342720868352/problems/994805378443755520

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format 

a1/b1 a2/b2

. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is 

number1 operator number2 = result

. Notice that all the rational numbers must be in their simplest form 

k a/b

, where 

k

 is the integer part, and 

a/b

 is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output 

Inf

 as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2
           

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)
           

Sample Input 2:

5/3 0/6
           

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
           

:題意  輸入兩個分數,輸出其四則運算的結果,如果除數為0,那麼相除的結果為inf       PAT(A)-1081

參考《算法筆記》分數的四則運算部分

注意:

  • 輸入的分數不一定是最簡的,輸出格式要求為最簡格式
  • 如果分數為負數的話用括号括起來
  • 輸出的結果為假分數
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
struct Fraction{
	ll up;//分子 
	ll down;//分母 
};
ll gcd(ll x,ll y){
	if(!y){
		return x;		
	}else{
		return gcd(y,x%y);
	}
} 
Fraction reduction(Fraction res){
	if(res.down<0){
		res.up=-res.up;
		res.down=-res.down;
	}
	if(res.up==0){ 
		res.down=1;
	}else{
		ll t=gcd(abs(res.up),abs(res.down));
		res.up/=t;
		res.down/=t; 
	} 
	return res;
}
Fraction add(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down+f2.up*f1.down;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction sub(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down-f2.up*f1.down;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction mul(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.up;
	res.down=f1.down*f2.down;
	return reduction(res);
}
Fraction div(Fraction f1,Fraction f2){
	Fraction res;
	res.up=f1.up*f2.down;
	res.down=f1.down*f2.up;
	return reduction(res);
}
void print(Fraction res){
	res=reduction(res);
	if(res.up<0){
		printf("(");
	}
	if(res.down==1){
		printf("%lld",res.up);
	}else if(abs(res.up)>res.down){
		ll t=abs(res.up);
		printf("%lld %lld/%lld",res.up/res.down,t%res.down,res.down);
	}else{
		printf("%lld/%lld",res.up,res.down);
	}
	if(res.up<0){
		printf(")");
	}
}
int main(){
	Fraction f1,f2;
	scanf("%lld/%lld %lld/%lld",&f1.up,&f1.down,&f2.up,&f2.down);
	f1=reduction(f1);
	f2=reduction(f2);
	char str[4][5]={"+","-","*","/"};
	for(int i=0;i<4;i++){
		print(f1);
		printf(" %s ",str[i]);
		print(f2);
		printf(" = ");
		switch(i){
			case 0:
				print(add(f1,f2)); 
				break;
			case 1:
				print(sub(f1,f2));
				break;
			case 2:
				print(mul(f1,f2));
				break;
			default: 
				if(f2.up==0){
					printf("Inf");
				}else{
					print(div(f1,f2));
				}		
		}
		printf("\n");
	}
	return 0;
} 
           
PAT (Advanced Level) Practice — 1088 Rational Arithmetic (20 分)