天天看點

pku3639 Exchange Rates (動态規劃)

Exchange Rates

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1942 Accepted: 647

Description

Now that the Loonie is hovering about par with the Greenback, you have decided to use your $1000 entrance scholarship to engage in currency speculation. So you gaze into a crystal ball which predicts the closing exchange rate between Canadian and U.S. dollars for each of the next several days. On any given day, you can switch all of your money from Canadian to U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3% commission, less any fraction of a cent.

Assuming your crystal ball is correct, what's the maximum amount of money you can have, in Canadian dollars, when you're done?

Input

The input contains a number of test cases, followed by a line containing 0. Each test case begins with 0 < d ≤ 365, the number of days that your crystal ball can predict. d lines follow, giving the price of a U.S. dollar in Canadian dollars, as a real number.

Output

For each test case, output a line giving the maximum amount of money, in Canadian dollars and cents, that it is possible to have at the end of the last prediction, assuming you may exchange money on any subset of the predicted days, in order.

Sample Input

3


1.0500


0.9300


0.9900


2


1.0500


1.1000


0


      

Sample Output

1001.60


1000.00





題目大意:給定d天的匯率,用1000 Canadian dollars和美元反複兌換,問最後最多能得到多少Canadian dollars, 每次兌換扣稅3%


動态規劃,


dp[i][usa] = Max(dp[j][can]/rate[i]*0.97), 1<=j<i;


dp[i][can] = Max(dp[j][usa]*rate[i]*0.97), 1<=j<i;


dp[i][usa]表示第i天能得到的最多USA dollars, 


dp[i][can]表示第i天能得到的最多Canadian dollars;





#include <iostream>
#include <iomanip>
using namespace std;

int  dp[366][2];  //0  means in US 
				  //1  means in Canadian
double  rate[366];
int  d;

#define  max(a,b)   ((a)>(b)?(a):(b))
int  main()
{
	int  i, j;
	double  ans;
	while (cin>>d && d)
	{
		for (i=1; i<=d; i++)
			cin >> rate[i];

		memset(dp, 0, sizeof(dp));
		dp[1][0] = 1000 / rate[1] * 0.97 * 100;
		dp[1][1] = 1000 * 100;
		for (i=2; i<=d; i++)
			for (j=1; j<i; j++)
			{
				dp[i][0] = max(dp[i][0], dp[j][1] * 0.97 / rate[i]);
				dp[i][1] = max(dp[i][1], dp[j][0] * 0.97 * rate[i]);
			}

		ans = 1000 * 100;
		for (i=1; i<=d; i++)
			ans = max(ans, dp[i][1]);
		cout << fixed << setprecision(2) << ans/100.0 << endl;
	}
	return 0;
}

 


      

繼續閱讀