天天看點

ZOJ3609——數論基礎 擴充歐幾裡得求解乘法逆元

原題如下:

Description

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that 

a-1≡x (mod m)

. This is equivalent to

ax≡1 (mod m)

.

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13
      

Sample Output

4
Not Exist
8      

題目大意:裸的求模的乘法逆元的題目,要注意得有要是正解。是以若解為負的,得加上解得間隔直到解為正數。間隔為m/gcd(a,m)。

代碼如下

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cctype>
#include <queue>
using namespace std;
           
//歐幾裡得算法
int gcd(int a,int b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
           
//擴充歐幾裡得算法
int exgcd(int a,int b,int &x,int &y)
{
    int d=a;
    if(b!=0)
    {
        d=exgcd(b,a%b,y,x);
        y-=(a/b)*x;
    }
    else
    {
        x=1;
        y=0;
    }
    return d;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int a,m;
        scanf("%d%d",&a,&m);
        if(gcd(a,m)!=1)//如果最大公因數不是1,則表明無解
        {
            printf("Not Exist\n");
            continue;
        }
        int x,y;
        exgcd(a,m,x,y);
        while(x<=0)
        {
            x+=m/gcd(a,m);//使結果為正數
        }
        printf("%d\n",x);
    }
}
           

繼續閱讀