Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14379 Accepted Submission(s): 6421
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
Author
Redow
注意精度即可。
#include<stdio.h>
#include<math.h>
double fx(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
int main()
{
int test;
double k,j,y;
scanf("%d",&test);
while(test--)
{
scanf("%lf",&y);
if(y>=fx(0)&&y<=fx(100))
{
k=0;
j=100;
while(j-k>=1e-7)
{
if(fx((k+j)/2)<y)
k=(k+j)/2;
else
j=(k+j)/2;
}
printf("%.4lf\n",(j+k)/2);
}
else
printf("No solution!\n");
}
}