天天看點

Eddy's research I(素數打表) Eddy's research I

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7398    Accepted Submission(s): 4477

Problem Description Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

11
9412
        

Sample Output

11
2*2*13*181
        

Author eddy  

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
int a[65540]={1,1},prim[65540];
int main()
{
    int i,len=0,n,flag;
    long long j;
    memset(a,0,sizeof(a));//标記是否為素數
    memset(prim,0,sizeof(prim));//記錄素數
    for(i=2;i<=sqrt(65535);i++)//由于i的範圍問題,導緻程式崩潰了!換成sqrt就可以了!
    {
        for(j=i*i;j<=65535;j+=i)
        {
            a[j]=1;
        }
    }
    for(i=2;i<=65535;i++)
    {
        if(!a[i])
        {
            prim[len++]=i;
        }
    }
    while(cin>>n)
    {
        flag=0;
       if(!a[n])
       {
           cout<<n<<endl;
       }
       else
       {
           for(i=0;i<len;i++)
           {
               while(n%prim[i]==0)
               {
                    if(flag)
                    {
                        cout<<"*"<<prim[i];
                        n/=prim[i];
                    }
                    else
                    {
                        cout<<prim[i];
                        flag++;
                        n/=prim[i];
                    }
                }
           }
           cout<<endl;
       }
    }
}