天天看點

Light OJ 1049 Farthest Nodes in a Tree(樹的直徑)(模闆題)

Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

題意:給出n個結點,和n-1條邊,求最長的一條邊,即樹的直徑.

樹的定義:沒有回路的無向連通圖。

樹的性質:

1,一棵樹中的任意兩個結點有且僅有唯一的一條路徑連通.

2,一棵樹如果有n個結點,那麼它一定恰好有n-1條邊.

3,在一棵樹中加一條邊會構成一個回路.

代碼如下:

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int MAXN=30000+10;
struct node{
	int from,to,next,val;
}edge[MAXN*2];
int head[MAXN];
int edgenum;
void init(){
	memset(head,-1,sizeof(head));
	edgenum=0;
}
void addedge(int u,int v,int w){
	edge[edgenum].from=u;
	edge[edgenum].to=v;
	edge[edgenum].val=w;
	edge[edgenum].next=head[u];
	head[u]=edgenum++;
}
int ans=0;
int pt;
int dist[MAXN];
bool vis[MAXN];
int n;
void bfs(int s)
{
	memset(dist,0,sizeof(dist));
	memset(vis,0,sizeof(vis));
	queue<int>que;
	que.push(s);
	vis[s]=true;
	dist[s]=0;
	ans=0;
	pt=s;
	while(!que.empty())
	{
		int u=que.front();
		que.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
	  {
		 int v=edge[i].to;
		  if(!vis[v])
		   {
            if(dist[v]<dist[u]+edge[i].val)
               {
            	 dist[v]=dist[u]+edge[i].val;
            	 if(ans<dist[v])
            	 {
            	 ans=dist[v];
            	 pt=v;	
				 }
            	 
			   }
			   
		  	vis[v]=true;
		    que.push(v);
	    	}
	
	   }	
	}

}
int main()
{
	int t,a,b,c,k=0;
	scanf("%d",&t);
	while(t--)
	{
		init();
		scanf("%d",&n);
		
		for(int i=0;i<n-1;i++)
		{
		scanf("%d%d%d",&a,&b,&c);
		addedge(a,b,c);	
		addedge(b,a,c);
		}
		bfs(0);
		bfs(pt);
		printf("Case %d: %d\n",++k,ans);
    }
}