天天看點

POJ 1458 Common Subsequence(最長公共子序列模版題)

Common Subsequence

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 53101 Accepted: 22026

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp      

Sample Output

4
2
0      

Source

Southeastern Europe 2003 題目大意:給兩個字元串,求最長公共子序列 AC代碼

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[5005],e[5004];
int dp[2][5005];
int main(){
	int n;
	while(scanf("%s%s",s,e)!=EOF){
		int n=strlen(s);
		int m=strlen(e);
	memset(dp,0,sizeof(dp));
	int ans=0;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			if(s[i-1]==e[j-1]){
				dp[i%2][j]=dp[(i-1)%2][j-1]+1;
			}
			else{
				dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
			}
			ans=max(dp[i%2][j],ans);
		}
	}
	printf("%d\n",ans);
	}
	return 0;
}