天天看點

POJ 2054 /HDU 1055 Color a Tree(貪心+并查集)

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.

POJ 2054 /HDU 1055 Color a Tree(貪心+并查集)

Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

Input

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 

Output

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

Sample Input

5 1 1 2 1 2 4 1 2 1 3 2 4 3 5 0 0

Sample Output

33

題意:給出一個樹以及他的節點及其權值,現在要把這個樹上的所有節點染色,染色規則是根節點可以随意染色,但是對于其他節點要染色它的父節點必須染色,每次染色的代價為T*A[i],其中T代表了目前是第幾次染色,求最小的染色總代價

思路:貪心 利用等效權值(該點包含的原始權值總和/該點包含的原始點數),不斷選取等效權值最大的點p,然後與其父節點fa結合,合并之前p與fa各自的染色順序是已知的,讓p中的第一個節點接着fa的最後一個節點染色,直到整個樹合并成一個節點,這個點存貯的順序即為節點順序

#include<iostream>
#include <cstdio>
using namespace std;
const int max_n=1010;
int pre[max_n];//pre[i]用來表示目前集合(包含i)的上個元素
int nex[max_n];//next[i]用來表示目前集合(包含i)的下個元素
int c[max_n];
int num[max_n];//num[i]表示目前集合(包含i)的元素個數
int visit[max_n];
int sum[max_n];//目前集合元素和
int father[max_n];//father[i]表示i的父元素
int n,r;
int find_max()
{ //找到目前權值最大的集合,合并後的點當做一個集合,也就是一個點
    double imax=0;
    int bh=-1;
    for(int i=1; i<=n; i++) {
        if(imax<(sum[i]*1.0)/num[i]&&visit[i]==0) {
            imax=(sum[i]*1.0)/num[i];
            bh=i;
        }
    }
    return bh;
}
void make(int x)
 { //聯合
    int i;
    for(i = father[x]; pre[i] != -1; i = pre[i]);//找到父元素所在的集合
    sum[i]+=sum[x];
    num[i]+=num[x];
    for(i= father[x]; nex[i] != -1; i = nex[i]);//找到父元素所在集合的底元素然後合并
    nex[i]=x;
    pre[x]=i;
    visit[x]=1;
}
int main()
{

    while(scanf("%d %d",&n,&r),n&&r) {
        for(int i=1; i<=n; i++) {        //初始化
            scanf("%d",&c[i]);
            sum[i]=c[i];
            visit[i] =0;
            pre[i] = nex[i] = -1;
            num[i] = 1;
        }
        for(int i = 1; i < n; i++) {
            int a,b;
            scanf("%d %d",&a,&b);
            father[b] = a;            //父子關系
        }
        int d;
        visit[r]=1;
        while(1) {
            d=find_max();
            if(d==-1)break;
            make(d);
        }
        int ans=0,cnt=1;
        for(int i=r; i!=-1; i=nex[i]) {
            ans+=cnt*c[i];
            cnt++;
        }
        printf("%d\n",ans);
    }
    return 0;
}