Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
題目大意:用有限大小的容器收集總價值盡可能大的骨頭,每個骨頭有自身的價值和占用空間。
分析:簡單的01背包,裸模闆套就行。
AC代碼:
#include <iostream>
#include <cstring>
using namespace std;
int dp[1005][1005],numc[1005],numv[1005];
int main() {
int T, v, c;
cin >> T;
while (T--) {
cin >> c >> v;
for (int i = 1; i <= c; i++) {
cin >> numv[i];
}
for (int i = 1; i <= c; i++) {
cin >> numc[i];
}
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= c; i++) {
for (int j = 0; j <= v; j++) {
if (j >= numc[i]) {
dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - numc[i]] + numv[i]);
} else dp[i][j] = dp[i - 1][j];
}
}
cout << dp[c][v] << endl;
}
}