天天看點

PAT (Advanced Level) 1009. Product of Polynomials (25) 多項式相乘

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5
      

Sample Output

3 3 3.6 2 6.0 1 1.6
      
使用vector<pair<int,double> > 存儲兩個多項式a和b,使用map<int,double>,以指數為key,底數為value,周遊a和b進行疊代,注意去除底數為0的項。      
/*2015.7.19cyq*/
#include <iostream>
#include <vector>
#include <map>
using namespace std;

int main(){
	int ka,kb;
	vector<pair<int,double> > a,b;
	cin>>ka;
	int tmp=ka;
	int c;
	double d;
	while(tmp--){
		cin>>c>>d;
		a.push_back(make_pair(c,d));//多項式a
	}
	cin>>kb;
	tmp=kb;
	while(tmp--){
		cin>>c>>d;
		b.push_back(make_pair(c,d));//多項式b
	}

	map<int,double> map;
	for(int i=0;i<ka;i++){
		for(int j=0;j<kb;j++){
				int exp=a[i].first+b[j].first;//指數相加
				map[exp]+=a[i].second*b[j].second;//底數相乘
				if(map[exp]==0)
					map.erase(exp);
		}
	}
	cout<<map.size();
	for(auto it=map.rbegin();it!=map.rend();++it){
		printf(" %d %0.1f",(*it).first,(*it).second);
	}

	return 0;
}