天天看點

HDU-1013 Digital Roots(水) Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 48260    Accepted Submission(s): 14998

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0
        

Sample Output

6
3
  
  
   題意是給定一個數(很大 用字元串處理)求這個數的各位數字之和,如果這個和大于10,再對這個和求各位數字之和,直到和小于10
  
  
   很神奇的一個事情是 當一個數取餘9時,如果能被整除,那麼這個數的各位數字之和就是9,否則這個數的各位數字之和就是這個數取餘9
  
  

  
  
   
           
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    char c[1000];
    int i,len,s;
    while(cin>>c)
    {
        int sum=0;
        len=strlen(c);
        if(c[0]=='0')break;
        for(i=0;i<len;i++)
            sum+=(c[i]-'0');
        cout<<(sum%9==0?9:sum%9)<<endl;
    }
    return 0;
}