天天看點

HDU 1013 Digital Roots(兩種方法,求數字根) Digital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 67949    Accepted Submission(s): 21237

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0
        

Sample Output

6
3
        

Source Greater New York 2000

原題連結:http://acm.hdu.edu.cn/showproblem.php?pid=1013

題意:求一個數的數字根,例如:39的各位數字和為3+9=12(不是一位數,繼續,1+2=3),是以結果為3

兩種方法: 1,模拟,各位數相加

 2:數字和對9取餘

AC代碼1:模拟

#include <iostream>
#include <cstring>
using namespace std;

int root(int n)
{
    if(n<10)
        return n;
    int sum = 0;
    while(n)
    {
        sum +=n%10;
        n/=10;
    }
    return root(sum);
}
int main()
{
    int n,sum;
    char a[100];
    while(cin>>a)
    {
        int length = strlen(a);
        if(length==1&&a[0]=='0'){
            break;
        }
        sum = 0;
        for(int i=0; i<length; i++)
        {
            sum +=a[i]-'0';
        }
        cout<<root(sum)<<endl;
    }
    return 0;
}
           

AC代碼2:

#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    char a[100];
    while(cin>>a)
    {
        int len=strlen(a);
        if(len==1&&a[0]=='0')
            break;
        int sum=0;
        for(int i=0;i<len;i++)
        {
            sum+=a[i]-'0';
        }
        sum%=9;
        if(sum==0) sum=9;
        cout<<sum<<endl;
    }

    return 0;
}