天天看點

POJ 3356 AGTC 解題報告(Edit Distance,DP)

AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9579 Accepted: 3659

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.
Illustration
A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C      

Deletion: * in the bottom line

Insertion: * in the top line

Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like
A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C      

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC      
Sample Output
4      

Source

Manila 2006

    解題報告: 今天比賽被坑的一個地方,題目中出現了Edit Distance,卻不知道具體是個什麼東西,一直以為用LCS就可以搞定,然後一直WA。 

    以為是LCS也有先入為主的思想在裡面,聽到别人這麼說,就直接以為就是這樣,沒有去想别的。

    Edit Distance就是兩個串通過添加一個字元,删除一個字元,修改一個字元這樣的變換,得到相同的串的步驟數。

    直接DP就好了。代碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char a[1111], b[1111];
int dp[1111][1111];

int dfs(int l, int r)
{
    if(l==0 && r==0) return 0;
    if(l==0 && r) return r;
    if(l && r==0) return l;

    if(~dp[l][r]) return dp[l][r];
    int &ans=dp[l][r];

    ans=min(min(dfs(l-1, r)+1, dfs(l, r-1)+1), dfs(l-1, r-1)+(a[l]!=b[r]));
    return ans;
}

int main()
{
    int lena, lenb;
    while(~scanf("%d%s%d%s", &lena, a+1, &lenb, b+1))
    {
        memset(dp, -1, sizeof(dp));
        printf("%d\n", dfs(lena, lenb));
    }
}