天天看點

HDU 5289 Assignment(2015 多校第一場二分 + RMQ) Assignment

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 627    Accepted Submission(s): 318

Problem Description Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.  

Input In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.  

Output For each test,output the number of groups.  

Sample Input

2
4 2
3 1 2 4
10 5
0 3 4 5 2 1 6 7 8 9
        

Sample Output

5
28

   
    
     Hint
    First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3] 
   
    
        

Author FZUACM  

Source 2015 Multi-University Training Contest 1

解題思路:

枚舉左端點,二分查找右端點,用RMQ維護區間最大值和最小值

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <vector>
#include <stack>
#define LL long long
using namespace std;
const int MAXN = 100000 + 10;
int A[MAXN];
int dp1[MAXN][20], dp[MAXN][20];
int N, M;
void RMQ_init_Min()
{
    for(int i=0;i<N;i++) dp1[i][0] = A[i];
    for(int j=1;(1<<j) <= N;j++)
    {
        for(int i=0;i+(1<<j) - 1 < N;i++)
        {
            dp1[i][j] = min(dp1[i][j-1], dp1[i + (1<<(j-1))][j-1]);
        }
    }
}
int RMQ_Min(int L, int R)
{
    int k = 0;
    while(1<<(k+1) <= R - L + 1) k++;
    return min(dp1[L][k], dp1[R-(1<<k)+1][k]);
}
void RMQ_init_Max()
{
    for(int i=0;i<N;i++) dp[i][0] = A[i];
    for(int j=1;(1<<j) <= N;j++)
    {
        for(int i=0;i+(1<<j) - 1 < N;i++)
        {
            dp[i][j] = max(dp[i][j-1], dp[i + (1<<(j-1))][j-1]);
        }
    }
}
int RMQ_Max(int L, int R)
{
    int k = 0;
    while(1<<(k+1) <= R - L + 1) k++;
    return max(dp[L][k], dp[R-(1<<k)+1][k]);
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &N, &M);
        for(int i=0;i<N;i++) scanf("%d", &A[i]);
        RMQ_init_Min();
        RMQ_init_Max();
        long long ans = 0;
        for(int i=0;i<N;i++)
        {
            int l = i, r = N-1;
            while(l <= r)
            {
                int mid = (l + r) >> 1;
                int low = RMQ_Min(i, mid);
                int high = RMQ_Max(i ,mid);
                //cout << l << ' ' << r << ' ' << high << ' ' <<low << endl;
                if(high - low < M) l = mid + 1;
                else r = mid - 1;
            }
            //cout << l << endl;
            ans += (l - i);
        }
        printf("%I64d\n", ans);
    }
    return 0;
}