天天看点

CSU 1563 Lexicography

An anagram of a string is any string that can be formed using the same letters as the original. (We consider the original string an anagram of itself as well.) For example, the string ACM has the following 6 anagrams, as given in alphabetical order:

ACM

AMC

CAM

CMA

MAC

MCA

As another example, the string ICPC has the following 12 anagrams (in alphabetical order):

CCIP

CCPI

CICP

CIPC

CPCI

CPIC

ICCP

ICPC

IPCC

PCCI

PCIC

PICC

Given a string and a rank K, you are to determine the Kth such anagram according to alphabetical order.

Input

Each test case will be designated on a single line containing the original word followed by the desired rank K. Words will use uppercase letters (i.e., A through Z) and will have length at most 16. The value of K will be in the range from 1 to the number of distinct anagrams of the given word. A line of the form "# 0" designates the end of the input.

Output

For each test, display the Kth anagram of the original string.

Sample Input

ACM 5

ICPC 12

REGION 274

# 0

Sample Output

MAC

PICC

IGNORE

Hint

The value of K could be almost 245 in the largest tests, so you should use type long in Java, or type long long in C++ to store K.

#include<cstdio>  
#include<cstring>
#include<cstdio>
#include<algorithm>  
using namespace std;
const int N = 1e5 + 10;
char s[N], a[N];
int m;
long long n;

long long calc(int x) {
  sort(s + x, s + m);
  long long ans = 1;
  for (int i = x; i < m; i++) ans *= i - x + 1;
  for (int i = x + 1, j = 1; i < m; i++) {
    if (s[i] == s[i - 1]) j++; else j = 1;
    ans /= j;
  }
  return ans;
}

void dfs(int x, long long rk) {
  for (int i = x; i < m; i++) a[i] = s[i];
  sort(a + x, a + m);
  int sz = unique(a + x, a + m) - a;
  for (int i = x; i < sz; i++) {
    for (int j = x; j < m; j++) {
      if (s[j] == a[i]) {
        swap(s[j], s[x]); 
        break;
      }
    }
    long long temp = calc(x + 1);
    if (rk > temp) {
      rk -= temp;
    } else {
      dfs(x + 1, rk);
      return;
    }
  }
}

int main(){
  while (~scanf("%s%lld", s, &n) && n) {
    m = strlen(s);
    dfs(0, n);
    printf("%s\n", s);
  }
  return 0;
}