天天看点

UVA 442 Matrix Chain Multiplication

Description

​​

​​

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

​​Input Specification​​

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( 

 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>Line = Expression <CR>

Expression = Matrix | "(" Expression Expression ")"

Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

​​Output Specification​​

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

​​Sample Input​​

9A 50 10

B 10 20

C 20 5

D 30 35

E 35 15

F 15 5

G 5 10

H 10 20

I 20 25

A

B

C

(AA)

(AB)

(AC)

(A(BC))

((AB)C)

(((((DE)F)G)H)I)

(D(E(F(G(HI)))))

((D(EF))((GH)I))

​​Sample Output​​

00

error

10000

error

3500

15000

40500

47500

15125

#include<map>
#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=105;
int n,m,ans,l,r;
char s[maxn*maxn];

struct martix
{
  int l,r;
  martix(){}
  martix(int l,int r):l(l),r(r){}
};

martix operator *(const martix&a,const martix&b)
{
  return martix(a.l,b.r);
}

map<char,martix> M;

int main()
{
  scanf("%d",&n);
  for (int i=1;i<=n;i++) 
  {
    scanf("%s%d%d",s,&l,&r);
    M[s[0]]=martix(l,r);
  }
  while (~scanf("%s",s))
  {
    stack<martix> p;
    bool flag=true;
    for (int i=ans=0;s[i];i++)
    {
      if (s[i]=='(') p.push(martix(-1,-1));
      else if (s[i]!=')') p.push(M[s[i]]);
      else 
      {
        martix b=p.top(); p.pop();
        martix a=p.top(); p.pop();
        p.pop();
        if (a.r!=b.l) {flag=false; break;}
        ans+=a.l*a.r*b.r;
        p.push(a*b);
      }
    }
    if (flag) printf("%d\n",ans);
    else printf("error\n");
  }
  return 0;
}