天天看点

ZOJ 3944 People Counting

People Counting

Time Limit: 2 Seconds      

Memory Limit: 65536 KB

In a BG (dinner gathering) for ZJU ICPC team, the coaches wanted to count the number of people present at the BG. They did that by having the waitress take a photo for them. Everyone was in the photo and no one was completely blocked. Each person in the photo has the same posture. After some preprocessing, the photo was converted into a H×W

.O.

/|\

(.)

Given the character matrix, the coaches want you to count the number of people in the photo. Note that if someone is partly blocked in the photo, only part of the above diagram will be presented in the character matrix.

Input

There are multiple test cases. The first line of input contains an integer T

The first contains two integers H, W (1 ≤ H, W ≤ 100) - as described above, followed by H

Output

For each test case, there should be a single line, containing an integer indicating the number of people from the photo.

Sample Input

2

3 3

.O.

/|\

(.)

3 4

OOO(

/|\\

()))

Sample Output

1

4

Author: 

Lu, Yi

Source: 

The 13th Zhejiang Provincial Collegiate Programming Contest

按照3*3的图统计,只要有一个点符合就加1

#include<queue>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e2 + 10;
int T, n, m;
char s[maxn][maxn];

bool check(int x, int y)
{
  if (1 <= x&&x <= n && 1 <= y + 1 && y + 1 <= m&&s[x][y + 1] == 'O') return true;
  if (1 <= x + 1 && x + 1 <= n && 1 <= y && y <= m&&s[x + 1][y] == '/') return true;
  if (1 <= x + 1 && x + 1 <= n && 1 <= y + 1 && y + 1 <= m&&s[x + 1][y + 1] == '|') return true;
  if (1 <= x + 1 && x + 1 <= n && 1 <= y + 2 && y + 2 <= m&&s[x + 1][y + 2] == '\\') return true;
  if (1 <= x + 2 && x + 2 <= n && 1 <= y  && y <= m&&s[x + 2][y] == '(') return true;
  if (1 <= x + 2 && x + 2 <= n && 1 <= y + 2 && y + 2 <= m&&s[x + 2][y + 2] == ')') return true;
  return false;
}

int main()
{
  scanf("%d", &T);
  while (T--)
  {
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++) scanf("%s", s[i] + 1);
    int ans=0;
    for (int i = -1; i <= n; i++)
    {
      for (int j = -1; j <= m; j++)
      {
        if (check(i, j)) ans++;
      }
    }
    printf("%d\n", ans);
  }
  return 0;
}