天天看点

UVA 270 Lining Up

How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

​​Input​​

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

​​Output​​

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 

The output consists of one integer representing the largest number of points that all lie on one line.

​​Sample Input​​

1

1 1

2 2

3 3

9 10

10 11

​​Sample Output​​

3

问在一条直线上的点最多有多少。

每次以一个点为标准算所有点到该点的斜率,统计有多少个一样的,垂直x轴要特判。

#include<iostream>  
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int maxn = 1005;
int a[maxn][2], t, i, j, n, tot, sum;
double b[maxn];
char s[100];

int main(){
  scanf("%d", &t); gets(s); gets(s);
  while (t--)
  {
    for (i = 0;gets(s); i++)
    {
      if (s[0] == '\0') break;
      sscanf(s, "%d%d", &a[i][0], &a[i][1]);
    }
    n = i;
    tot = 0;
    for (i = 0; i < n; i++)
    {
      for (j = 0; j < n; j++)
      if (a[j][0] == a[i][0])  if (i != j) b[j] = -100; else b[j] = -200;
      else b[j] = 1.0*(a[i][1] - a[j][1]) / (a[i][0] - a[j][0]);
      sort(b, b + n);
      for (sum = 1, j = 0; j < n; j++)
      if (b[j] == b[j + 1] && j + 1 < n) sum++; else { tot = max(tot, sum); sum = 1; }
    }
    printf("%d\n", tot + 1);
    if (t) printf("\n");
  }
  return 0;
}