天天看点

PAT (Advanced Level) Practise 1003 Emergency (25)

1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1      

Sample Output

2 4      

用dijkstra算法求出最短路,顺便统计数量和最大值。

#include<cstdio>  
#include<queue>  
#include<cstring>  
#include<algorithm>  
using namespace std;
const int maxn = 5e2 + 10;
int n, m, s, t, x, y, z;
int v[maxn], dis[maxn], map[maxn][maxn], vis[maxn], ans[maxn];
long long cnt[maxn];

int main()
{
  scanf("%d%d%d%d", &n, &m, &s, &t);
  for (int i = 0; i<n; i++) scanf("%d", &v[i]);
  memset(map, -1, sizeof(map));
  memset(dis, -1, sizeof(dis));
  while (m--)
  {
    scanf("%d%d%d", &x, &y, &z);
    map[x][y] = map[y][x] = z;
  }
  ans[s] = v[s]; dis[s] = 0;  cnt[s] = 1;
  while (true)
  {
    int now = -1;
    for (int i = 0; i<n; i++)
      if (!vis[i] && dis[i] != -1)
      {
        if (now == -1) now = i; else now = dis[now] < dis[i] ? now : i;
      }
    if (now == -1) break;
    vis[now] = 1;
    for (int i = 0; i < n; i++)
    {
      if (map[now][i] != -1)
      {
        if (dis[i] == -1 || dis[i]>dis[now] + map[now][i])
        { 
          dis[i] = dis[now] + map[now][i]; 
          cnt[i] = cnt[now]; ans[i] = ans[now] + v[i];
        }
        else if (dis[i] == dis[now] + map[now][i]) cnt[i] += cnt[now], ans[i] = max(ans[i], ans[now] + v[i]);
      }
    }
  }
  printf("%lld %d\n", cnt[t], ans[t]);
  return 0;
}