天天看点

ZOJ 3947 Very Happy Great BG

Very Happy Great BG

Time Limit: 2 Seconds      

Memory Limit: 65536 KB

The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coach of ZJU ICPC Team decided to BG everyone!

After a brief discussion, they decided to go to Lou Wai Lou to have a great dinner. Each team member can bring some friends with him/her. Of course, they need to tell the coach the number of friends they will bring.

Now the coach wants to know the total number of participants (excluding the coach himself). Please tell him.

Input

There are multiple test cases. The first line of input contains an integer T

The first line contains an integer N (1 <= N

The second line contains N non-negative integers, the i-th integer indicates the number of friends (< 1000) that the i-th team member will bring.

Output

For each test case, output the total number of participants.

Sample Input

4
5
0 0 1 2 3
1
0
10
1 2 3 4 5 6 7 8 9 10
2
5 3      

Sample Output

11
1
65
10      

Author: 

DAI, Longao

Source: The 13th Zhejiang Provincial Collegiate Programming Contest

水题

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 4;
int T, n, x;

int main()
{
  scanf("%d", &T);
  while (T--)
  {
    scanf("%d", &n);
    int ans = n;
    while (n--) scanf("%d", &x), ans += x;
    printf("%d\n", ans);
  }
  return 0;
}      

Very Happy Great BG

Time Limit: 2 Seconds      

Memory Limit: 65536 KB

The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coach of ZJU ICPC Team decided to BG everyone!

After a brief discussion, they decided to go to Lou Wai Lou to have a great dinner. Each team member can bring some friends with him/her. Of course, they need to tell the coach the number of friends they will bring.

Now the coach wants to know the total number of participants (excluding the coach himself). Please tell him.

Input

There are multiple test cases. The first line of input contains an integer T

The first line contains an integer N (1 <= N

The second line contains N non-negative integers, the i-th integer indicates the number of friends (< 1000) that the i-th team member will bring.

Output

For each test case, output the total number of participants.

Sample Input

4
5
0 0 1 2 3
1
0
10
1 2 3 4 5 6 7 8 9 10
2
5 3      

Sample Output

11

1

65

10

Author: 

DAI, Longao