天天看点

PAT (Advanced Level) Practise 1086 Tree Traversals Again (25)

1086. Tree Traversals Again (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop      

Sample Output:

3 4 2 6 5 1      

用栈模拟弄出二叉树然后输出后序遍历。

#include<cstdio>
#include<stack>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
int n, ch[maxn][2], root, x, bef, vec;
stack<int> p;
char s[maxn];

void dfs(int x)
{
  if (!x) return;
  dfs(ch[x][0]);
  dfs(ch[x][1]);
  printf("%d%s", x, root == x ? "\n" : " ");
}

int main()
{
  scanf("%d", &n);  n <<= 1;
  while (n--)
  {
    scanf("%s", s);
    if (strcmp(s, "Push"))
    {
      bef = p.top(); vec = 1;
      p.pop();
    }
    else
    {
      scanf("%d", &x);
      if (!root) root = x;
      ch[bef][vec] = x;
      bef = x;  vec = 0;
      p.push(x);
    }
  }
  dfs(root);
  return 0;
}      
下一篇: