天天看点

HDU 4861 Couple doubi

DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.

Input

Multiply Test Cases. 

In the first line there are two Integers k and p(1<k,p<2^31). 

Output

For each line, output an integer, as described above.

Sample Input

2 3
20 3      

Sample Output

YES

NO

#include<cstdio>
#include<cstring>
#include<cmath>
#include<stack>
#include<algorithm>
using namespace std;
int k,p;

int main()
{
    while(~scanf("%d%d",&k,&p))
    {
        /*
        for (int i=1;i<=k;i++)
        {
            int res=0;
            for (int j=1;j<p;j++)
            {
                int now=1;
                for (int k=1;k<=i;k++)
                {
                    now=now*j%p;
                }
                res=(res+now)%p;
            }
            printf("%d %d\n",i,res);
        }*/
        puts(k/(p-1)%2?"YES":"NO");
    }
    return 0;
}