天天看点

HDU 3760 Ideal Path

Problem Description

New labyrinth attraction is open in New Lostland amusement park. The labyrinth consists of n rooms connected by m passages. Each passage is colored into some color ci. Visitors of the labyrinth are dropped from the helicopter to the room number 1 and their goal is to get to the labyrinth exit located in the room number n.

Labyrinth owners are planning to run a contest tomorrow. Several runners will be dropped to the room number 1. They will run to the room number n writing down colors of passages as they run through them. The contestant with the shortest sequence of colors is the winner of the contest. If there are several contestants with the same sequence length, the one with the ideal path is the winner. The path is the ideal path if its color sequence is the lexicographically smallest among shortest paths.

Andrew is preparing for the contest. He took a helicopter tour above New Lostland and made a picture of the labyrinth. Your task is to help him find the ideal path from the room number 1 to the room number n that would allow him to win the contest.

Note

A sequence (a1, a2, …, ak) is lexicographically smaller than a sequence (b1, b2, …, bk) if there exists i such that ai < bi, and aj = bj for all j < i.

Input

The input begins with an integer T. The next T blocks each represents a case. The first line of each case contains integers n and m - the number of rooms and passages, respectively (2 ≤ n ≤ 100 000, 1 ≤ m ≤ 200 000). The following m lines describe passages, each passage is described with three integer numbers: ai, bi, and ci - the numbers of rooms it connects and its color (1 ≤ ai, bi ≤ n, 1 ≤ ci ≤ 109). Each passage can be passed in either direction. Two rooms can be connected with more than one passage, there can be a passage from a room to itself. It is guaranteed that it is possible to reach the room number n from the room number 1.

Output

For each case, the first line of the output must contain k - the length of the shortest path from the room number 1 to the room number n. The second line must contain k numbers - the colors of passages in the order they must be passed in the ideal path.

Sample Input

1
4 6
1 2 1
1 3 2
3 4 3
2 3 1
2 4 4
3 1 1      

Sample Output

2
1 3      

最短路+字典序最小,bfs更新的时候+优先队列并且要去重

#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define rep(i,j,k) for (int i = j; i <= k; i++)
const int N = 4e5;
int n, m, T, x, y, z;
int ft[N], nt[N], u[N], v[N], sz;
int d[N][2], t[N];

void bfs(int x, int t)
{
  queue<int> p; p.push(x);  d[x][t] = 0;
  while (!p.empty())
  {
    int q = p.front(); p.pop();
    for (int i = ft[q]; i != -1; i = nt[i])
    {
      if (d[u[i]][t] != -1) continue;
      d[u[i]][t] = d[q][t] + 1;
      p.push(u[i]);
    }
  }
}

struct point
{
  int x, y;
  point(int x = 0, int y = 0) :x(x), y(y) {};
  bool operator<(const point &a)const { return y > a.y; }
};

void Bfs()
{
  printf("%d\n", d[n][0]);
  priority_queue<point> pp; 
  queue<int> p; p.push(1);
  int flag = 0;
  for (int j = 1; j <= d[n][0]; j++)
  {
    while (!p.empty())
    {
      int q = p.front(); p.pop();
      for (int i = ft[q]; i != -1; i = nt[i])
      {
        if (d[u[i]][0] + d[u[i]][1] != d[n][0]) continue;
        if (d[u[i]][0] != d[q][0] + 1) continue;
        pp.push(point(u[i], v[i]));
      }
    }
    int q = pp.top().y, qq;
    while (!pp.empty() && pp.top().y == q)
    {
      qq = pp.top().x;
      if (t[qq] < j) p.push(pp.top().x), t[qq] = j;
      pp.pop();
    }
    while (!pp.empty()) pp.pop();
    if (flag) printf(" "); else flag = 1;
    printf("%d", q);
  }
  putchar(10);
}

int main()
{
  scanf("%d", &T);
  while (T--)
  {
    scanf("%d%d", &n, &m);
    memset(ft, -1, sizeof(ft));
    memset(d, -1, sizeof(d));
    memset(t, 0, sizeof(t));
    for (sz = 0; m; m--)
    {
      scanf("%d%d%d", &x, &y, &z);
      u[sz] = y; v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
      u[sz] = x; v[sz] = z; nt[sz] = ft[y]; ft[y] = sz++;
    }
    bfs(1, 0);   bfs(n, 1);    Bfs();
  }
  return 0;
}