天天看点

PAT (Advanced Level) Practise 1008 Elevator (20)

1008. Elevator (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.      

Sample Input:

3 2 3 1      

Sample Output:

41

没什么好说的,直接模拟即可

#include<cstdio>
#include<stack>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5 + 10;
int n, l, r, ans;

int main()
{
  scanf("%d", &n);
  for (int i = 1; i <= n; i++)
  {
    scanf("%d", &r);
    if (r > l) ans += (r - l) * 6;
    if (r < l) ans += (l - r) * 4;
    ans += 5;  l = r;
  }
  printf("%d\n", ans);
  return 0;
}