天天看点

PAT (Advanced Level) Practise 1037 Magic Coupon (25)

1037. Magic Coupon (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3      

Sample Output:

43      

贪心,把正数和负数分开处理,正数从大到小排序,负数从小到大排序,然后每次取端点两个相乘就好了。

#include<cstdio>
#include<string>
#include<stack>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
const int maxn = 1e5 + 10;
typedef long long LL;
int n, x, ans;
int a[2][maxn], b[2][maxn];

int main()
{
  scanf("%d", &n);
  for (int i = 1; i <= n; i++)
  {
    scanf("%d", &x);
    if (x > 0) a[0][++a[0][0]] = x;
    else a[1][++a[1][0]] = x;
  }
  scanf("%d", &n);
  for (int i = 1; i <= n; i++)
  {
    scanf("%d", &x);
    if (x > 0) b[0][++b[0][0]] = x;
    else b[1][++b[1][0]] = x;
  }
  sort(a[0] + 1, a[0] + a[0][0] + 1, greater<int>());
  sort(b[0] + 1, b[0] + b[0][0] + 1, greater<int>());
  sort(a[1] + 1, a[1] + a[1][0] + 1);
  sort(b[1] + 1, b[1] + b[1][0] + 1);
  for (int i = 1; i <= min(a[0][0], b[0][0]); i++) ans += a[0][i] * b[0][i];
  for (int i = 1; i <= min(a[1][0], b[1][0]); i++) ans += a[1][i] * b[1][i];
  printf("%d\n", ans);
  return 0;
}