天天看点

PAT (Advanced Level) Practise 1015 Reversible Primes (20)

1015. Reversible Primes (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2      

Sample Output:

Yes
Yes

No      
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e3 + 10;
int n, d, ch[maxn], tot, flag, rev;

bool check(int x)
{
  if (x < 2) return false;
  for (int i = 2; i*i <= x; i++)
  {
    if (x%i == 0) return false;
  }
  return true;
}

int main()
{
  while (scanf("%d", &n), n >= 0)
  {
    scanf("%d", &d); flag = 1;  rev = tot = 0;
    for (int i = n; i; i /= d) ch[tot++] = i%d;
    for (int i = 0; i < tot; i++) rev = rev*d + ch[i];
    if (check(n) && check(rev)) printf("Yes\n");
    else printf("No\n");
  }
  return 0;
}