天天看点

PAT (Advanced Level) Practise 1009 Product of Polynomials (25)

1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5      

Sample Output

3 3 3.6 2 6.0 1 1.6      

和之前那个加法一样,注意0的问题

#include<cstdio>
#include<stack>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5 + 10;
int n, x, cnt;
double a[maxn], b[maxn], c[maxn];

int main()
{
  scanf("%d", &n);
  while (n--)
  {
    scanf("%d", &x);
    scanf("%lf", &a[x]);
  }
  scanf("%d", &n);
  while (n--)
  {
    scanf("%d", &x);
    scanf("%lf", &b[x]);
  }
  for (int i = 0; i < 1001; i++)
  {
    for (int j = 0; j < 1001; j++) c[i + j] += a[i] * b[j];
  }
  for (int i = 0; i < 2001; i++) if (c[i] != 0) cnt++;
  printf("%d", cnt);
  for (int i = 2000; i >= 0; i--) if (c[i] != 0) printf(" %d %.1lf", i, c[i]);
  return 0;
}