天天看点

PAT (Advanced Level) Practise 1078 Hashing (25)

1078. Hashing (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4

10 6 4 15

Sample Output:

0 1 4 -

先预处理一下素数吧。

二次探测再散列,hash表的内容看的真不多,题目也不解释一下,有毒。

#include<cstdio>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
const int INF = 0x7FFFFFFF;
const int maxn = 1e5 + 15;
int n, m, vis[maxn], x;
int f[maxn], a[maxn], tot;

void init()
{
  f[0] = f[1] = 1;
  for (int i = 2; i < maxn; i++)
  {
    if (!f[i]) a[tot++] = i;
    for (int j = 0; j < tot&&i*a[j] < maxn; j++)
    {
      f[i*a[j]] = 1;
    }
  }
}

int main()
{
  init();
  scanf("%d%d", &m, &n);
  while (f[m]) m++;
  while (n--)
  {
    scanf("%d", &x);
    int flag = 0;
    for (int i = 0; i < m; i++)
    {
      if (!vis[(x + i*i)%m])
      {
        vis[(x + i*i)%m] = 1;
        printf("%d", (x + i*i) % m);
        flag = 1; break;
      }
    }
    if (!flag) printf("-");
    printf("%s", n ? " " : "\n");
  }
  return 0;
}