天天看点

UVA 193 Graph Coloring

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

Figure: An optimal graph with three black nodes

​​Input and Output​​

The graph is given as a set of nodes denoted by numbers 

 , 

 , and a set of undirected edges denoted by pairs of node numbers 

 , 

 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

​​Sample Input​​

16 81 2

1 3

2 4

2 5

3 4

3 6

4 6

5 6

​​Sample Output​​

3

1 4 5

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn = 101;
int t, sum, n, m;
int f[maxn][maxn], c[maxn], d[maxn];

bool check(int x)
{
  for (int i = 1; i <= f[x][0];i++)
    if (c[f[x][i]] == c[x]) return false;
  return true;
}

void work(int x, int tot)
{
  if (x > n) 
  { 
    if (sum<tot)
    {
      sum = tot;  tot = 0;
      for (int i = 1; i <= n; i++) 
      if (c[i] > 0) d[tot++] = i;
    }
    return; 
  };
  if (tot + n - x + 1 < sum) return;
  c[x] = 1; if (check(x)) work(x + 1, tot + 1);
  c[x] = -1;  work(x + 1, tot);
}

int main()
{
  cin >> t;
  while (t--)
  {
    cin >> n >> m;
    memset(f, 0, sizeof(f));
    memset(c, 0, sizeof(c));
    for (int i = 0; i < m; i++)
    {
      int a, b;
      cin >> a >> b;
      f[a][++f[a][0]] = b;
      f[b][++f[b][0]] = a;
    }
    sum = 0;   work(1, 0);
    cout << sum << endl << d[0];
    for (int i = 1; i < sum; i++) cout << " " << d[i];
    cout << endl;
  }
  return 0;
}