天天看点

UVA 674 Coin Change

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

​​Input​​ 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

​​Output​​ 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

​​Sample Input​​ 

11

26

​​Sample Output​​ 

4

13

简单的背包问题,直接预处理然后输出即可。

#include<iostream>  
#include<algorithm>
#include<math.h>
#include<cstdio>
#include<string>
using namespace std;
const int maxn = 10000;
int i, j, n, a[5] = { 1, 5, 10, 25, 50 }, f[maxn];

int main()
{
  for (f[0] = 1, j = 0; j < 5; j++)
    for (i = 0; i <= maxn;i++) f[i + a[j]] += f[i];
  while (cin >> n) cout << f[n] << endl;
  return 0;
}