天天看点

HDU 1829 A Bug's Life

Problem Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:

Suspicious bugs found!

Scenario #2:

No suspicious bugs found!

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 2005;
int T, n, m, x, y, dis[maxn], fa[maxn], f;

int find(int x)
{
  if (x != fa[x]){ 
    int t = find(fa[x]);
    dis[x] = (dis[x] + dis[fa[x]]) % 2;
    fa[x] = t;
  }
  return fa[x];
}

void merge(int x, int y)
{
  int fx = find(x), fy = find(y);
  if (fx == fy)
  {
    if (dis[x] == dis[y]) f = 0;
    return;
  }
  fa[fx] = fy;
  dis[fx] = (1 + dis[x] + dis[y]) % 2;
}

int main(){
  scanf("%d", &T);
  for (int i = 1; i <= T; i++)
  {
    f = 1;
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++) fa[i] = i, dis[i] = 0;
    while (m--)
    {
      scanf("%d%d", &x, &y);
      if (f) merge(x, y);
    }
    printf("Scenario #%d:\n", i);
    if (f) printf("No suspicious bugs found!\n\n");
    else printf("Suspicious bugs found!\n\n");
  }
  return 0;
}