天天看点

UVA 531 Compromise

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:

Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.

​​Input Specification​​ 

The input file will contain several test cases.

#'.

Input is terminated by end of file.

​​Output Specification​​ 

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

​​Sample Input​​ 

die einkommen der landwirte

sind fuer die abgeordneten ein buch mit sieben siegeln

um dem abzuhelfen

muessen dringend alle subventionsgesetze verbessert werden

#

die steuern auf vermoegen und einkommen

sollten nach meinung der abgeordneten

nachdruecklich erhoben werden

dazu muessen die kontrollbefugnisse der finanzbehoerden

dringend verbessert werden

#

​​Sample Output​​ 

die einkommen der abgeordneten muessen dringend verbessert werden

最长公共子序列变形,保存路径。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<string>
using namespace std;
const int maxn = 110;
int sa, sb, p[maxn][maxn][maxn] = { 0 };
string a[maxn], b[maxn];

int main()
{
  while (cin >> a[0]){
    for (int i = 1;; i++)
    {
      cin >> a[i];  sa = i;
      if (a[i] == "#") break;
    }
    for (int i = 0;; i++)
    {
      cin >> b[i];  sb = i;
      if (b[i] == "#") break;
    }
    memset(p, 0, sizeof(p));
    for (int i = 0; i < sa; i++)
    for (int j = 0; j < sb; j++)
    if (a[i] == b[j])
    {
      p[i + 1][j + 1][0] = p[i][j][0] + 1;
      for (int k = 1; k < p[i + 1][j + 1][0]; k++) p[i + 1][j + 1][k] = p[i][j][k];
      p[i + 1][j + 1][p[i + 1][j + 1][0]] = i;
    }
    else
    {
      int u = i + 1, v = j + 1;
      if (p[i][j + 1][0] >= p[i + 1][j][0]) u--; else v--;
      p[i + 1][j + 1][0] = p[u][v][0];
      for (int k = 1; k <= p[i + 1][j + 1][0]; k++) p[i + 1][j + 1][k] = p[u][v][k];
    }
    for (int i = 1; i < p[sa][sb][0]; i++) cout << a[p[sa][sb][i]] << " ";
    cout << a[p[sa][sb][p[sa][sb][0]]] << endl;
  }
  return 0;
}