天天看点

PAT甲级1038 Recover the Smallest Number (30 分)题目大意:思路:参考代码:

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

Sample Output:

题目大意:

     给出n个数字段,可以随意的组合起来,要求最小的组合数。注意前头有0时不能输出。

思路:

     用 cmp 进行排序即可。

参考代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n;
vector<string> num;
bool cmp(string a, string b){return a + b < b + a;}
int main(){
	scanf("%d", &n);
	num.resize(n);
	for(int i = 0; i < n; ++i)	cin >> num[i];
	sort(num.begin(), num.end(), cmp);
	string ans;
	for(int i = 0; i < num.size(); ++i)	ans += num[i];
	while(ans.size() && ans[0] == '0')	ans.erase(ans.begin());
	if(!ans.size())	printf("0\n");
	else	cout << ans;
	return 0; 
}